登録日: 2018年1月17日
最終更新日: 2018年1月17日
コンテンツID: 00458
対象環境
DocuWorks 9
概要
生成されたDocuWorks文書の中身が異なる現象について解説します。
原因
DocuWorks Printerに出力指示した後、DocuWorks変換処理中にキャンセルすると、タイミングによっては変換処理中のプリントジョブが DocuWorks Printerに残った状態になります。
この状態で別の文書をDocuWorks Printerに出力指示すると、前のプリントジョブがDocuWorks変換される為、変換前と中身が異なる文書ができます。
これは、アプリケーション文書のデータをプリンタードライバーに送信するアプリケーション、Print Spoolerサービスから呼び出されるプリンタードライバー、DocuWorks Deskの3つの異なるプロセスが変換処理を実施することによる動作制限となります。
対処方法
再度、DocuWorks Printerに出力指示し、変換前と中身が同じか確認してください。
もし、中身が異なるようでしたら、まだDocuWorks Printerにプリントジョブが残っている可能性がありますので、以下の手順で、プリントジョブを削除し、ジョブがないことを確認した上で再度DocuWorks Printerに出力指示してください。
- [コントロールパネル]>[ハードウェアとサウンド]>[デバイスとプリンター]を開きます。
- DocuWorks Printerを右クリックし、[印刷ジョブの表示]を選択します。
- DocuWorks Printerにプリントジョブが表示されている場合は、そのプリントジョブを選択し、マウスを右クリックし[キャンセル] を選択して、プリントジョブを削除します。キーボードの「Delete」キーでも削除可能です。
- DocuWorks Printerに出力指示します。