ApeosWare Management Suite 2 Popup Messenger 2.1.3に バージョンアップしたところ、 Popup Messengerが起動しなくなりました
現象
ApeosWare Management Suite 2 Popup Messenger 2.1.3にバージョンアップしたところ、Popup Messengerが起動しなくなりました。
発生条件
ApeosWare Management Suite 2 Popup Messenger 2.1.3がインストールされているPCで、サーバー証明書検証の設定を実施していない場合
原因
ApeosWare Management Suite 2 Popup Messenger 2.1.3で、サーバー証明書の検証を実施修正したためです。
サーバー証明書検証は、デフォルトで有効になっています。
対策
1または2のいずれかの対策を実施してください。
1 ApeosWare Management Suiteサーバーを暗号化(SSL化)してご利用の場合
1-1 ApeosWare Management Suiteサーバー通信の暗号化(SSL化)
ApeosWare Management SuiteサーバーがSSL化されていない場合は、ApeosWare Management Suiteサーバーに証明書を設定し、サーバーの通信をSSL化してください。
- 注記 設定変更前に、CA(証明機関、認証局)からサーバー証明書を入手する必要があります。
- 注記 設定変更時は、ApeosWare Management Suiteサーバーを再起動する必要があります。
サーバーの通信をSSL化する手順は、メディアに同梱されている『ApeosWare Management Suite 2 機能ガイド 総合編』の以下のページを参照してください。
- 「メンテナンス」> 「サーバーの情報の変更」の「概要」
- 「メンテナンス」> 「サーバーの情報の変更」の「実行例」>「オールインワン構成でサーバーの通信を暗号化(SSL)する場合」注1
1-2 ApeosWare Management Suiteサーバー証明書の導入
Popup MessengerがインストールされているPCへApeosWare Management Suiteサーバー証明書を導入してください。
サーバー証明書の導入手順は、Popup Messenger 2.1.3のリリースノートの「ApeosWare Management Suiteサーバー証明書の導入方法」を参照してください。
- 注記 手順実施後、Popup Messengerを再起動する必要があります。
2 ApeosWare Management Suiteサーバーを暗号化(SSL化)せずにご利用の場合
Popup MessengerがインストールされているPCで、証明書検証を無効化してください。
検証方法の無効化する手順は、Popup Messenger 2.1.3のリリースノートの「Popup Messengerの証明書検証設定の変更方法」を参照してください。
- 注記 手順実施後、Popup Messengerを再起動する必要があります。
補足:「サーバー証明書をIISのWebサイトに設定する」手順
- 注1 「サーバー証明書をIISのWebサイトに設定する」手順は、以下の通りです。
1、2の手順を実施してください。
- 証明書ストアへの証明書の登録
- 証明書ファイルをダブルクリックし、[全般]タブで[証明書のインストール(I)...]を選択します。
- [証明書のインポート ウィザードの開始]で[ローカルコンピューター]を選択します。
- [証明書ストア]で以下を選択します。
ルート証明書の場合:信頼されたルート証明機関
中間証明書の場合:中間証明機関
サーバー証明書の場合:個人 - [証明書のインポート ウィザードの完了]で[完了]を選択します。
- サーバー証明書のバインド
- インターネットインフォメーションサービス(IIS)マネージャーを開きます。
- [サーバー証明書]を選択します。
- [操作]バー > [インポート...]をクリックし、証明書をインポートします。
- ApeosWare Management Suite のサイトを選択します。
- [操作]バー > [バインド...]をクリックします。
- [種類]がhttpsのバインドを選択して、[編集]ボタンをクリックします。
- [SSL証明書]にApeosWare Management Suiteのホスト名と同じ発行先の証明書を選択して、[OK]ボタンをクリックします。
- 注記 Windows Server 2016での実行例です。