ApeosWare Management Suite 2.0.0.8で、[管理者画面]にアクセスできない。
現象
ApeosWare Management Suite 2.0.0.8がインストールされたオールインワン構成のサーバー/分散構成のメインサーバーで、AWMSHostnameSetup.exeを使用しホスト名またはIPアドレスを変更すると、[管理者画面]にアクセスできなくなりました。
また、分散構成のプリントアプリケーションサーバー/プリント入出力サーバーで、AWMSHostnameSetup.exeを使用しホスト名またはIPアドレスを変更すると、[管理者画面]から変更したサーバーにアクセスすることができなくなりました。
発生条件
以下のコマンドでホスト名またはIPアドレスを変更するとき、本現象が発生します。
AWMSHostnameSetup.exe -N {変更後のホスト名またはIPアドレス}
<対象サーバー>
- オールインワン構成のApeosWare Management Suite 2.0.0.8がインストールされたサーバー
- 分散構成のApeosWare Management Suite 2.0.0.8メインサーバー
- 分散構成のApeosWare Management Suite 2.0.0.8プリントアプリケーションサーバー
- 分散構成のApeosWare Management Suite 2.0.0.8プリント入出力サーバー
原因
ApeosWare Management Suiteの不具合です。AWMSHostnameSetup.exe -N {変更後のホスト名またはIPアドレス}を実行したときに、SSL証明書の設定に不具合があり、必要な設定が正しく更新できません。そのため、[管理者画面]へのアクセスに失敗します。
対策
以下の手順に従ってSSL証明書をバインドしてください。
- 注記 AWMSHostnameSetup.exeの-Nオプションでホスト名またはIPアドレスを変更した後に、必ず以下の手順を実施してください。
SSL証明書のバインド手順
ApeosWare Management Suiteをインストールしたメインサーバー/プリントアプリケーションサーバー/プリント入出力サーバーで、以下の手順を実施してください。
環境をSSL構成で構築していない場合:
- インターネットインフォメーションサービス(IIS)マネージャーを開きます。
- ApeosWare Management Suite 2のサイトを選択します。
- [操作]バー > [バインド...]をクリックします。
- [種類]がhttpsのバインドを選択して、[編集]ボタンをクリックします。
- [SSL証明書]にApeosWare Management Suiteのホスト名と同じ発行先の証明書を選択して、[OK]ボタンをクリックします。
- OSを再起動します。
環境をSSL構成で構築している場合:
以下、インストール時に[インストール先]として指定したフォルダーを<INSTALLDIR>で示します。
デフォルトでは以下のとおりです。
(32ビットOSの場合) C:\Program Files\Fuji Xerox\ApeosWare MS 2\
(64ビットOSの場合) C:\Program Files (x86)\Fuji Xerox\ApeosWare MS 2\
- コマンドプロンプトを管理者権限で起動します。
- 以下のフォルダーに移動します。
<INSTALLDIR>\Utils\Hostname Setting - 以下のコマンドを実行します。
AWMSHostnameSetup.exe -G - [ポート番号]の値<port>を記録します。
- インターネットインフォメーションサービス(IIS)マネージャーを開きます。
- ApeosWare Management Suite 2のサイトを選択します。
- [操作]バー > [バインド...]をクリックします。
- [種類]がhttpsのバインドを選択して、[削除]ボタンをクリックします。
- マニュアル(ApeosWare Management Suite 2 機能ガイド総合編)の[2.4 準備] > [セットアップするときに通信を暗号化(SSL)する場合]にしたがって、証明書をバインドします。
- 注記 [種類]がhttps、[ポート]が手順4の<port>であるバインドがすでに存在する場合、手順10, 11の実施は必要ありません。
- [追加]ボタンをクリックします。
- [種類]にhttp、[ポート]に<port>を設定して、[OK]ボタンをクリックします。
- OSを再起動します。