Flow Management Option2.1において、[フロー管理画面]にアクセスできなくなることがあります。
現象
ApeosWare Management Suite 2.1 Flow Management Optionがインストールされたサーバーで、ホスト名設定ツールを使用しホスト名またはIPアドレスを変更すると、Flow Management Optionの管理画面にアクセスできなくなることがあります。
原因
ApeosWare Management Suiteの不具合です。AWMSHostnameSetup.exe -D {データベースのホスト名} -DEを実行しても、Flow Management Optionのデータベースのホスト名が正しく更新できません。そのため、AWMSHostnameSetup.exeの実行後に[フロー管理画面]へアクセスすると、古いホスト名でデータベースにアクセスしようとして、[フロー管理画面]への遷移に失敗します。
本現象は以下の条件で発生します。
- オールインワン構成のFlow Management Optionがインストールされたサーバーで、ホスト名またはIPアドレスを変更する。
AWMSHostnameSetup.exe -N {変更後のホスト名またはIPアドレス} -D {データベースのホスト名} -DE - 分散構成のFlow Management Optionがインストールされたサーバーで、ホスト名またはIPアドレスを変更する。
AWMSHostnameSetup.exe -N {変更後のホスト名またはIPアドレス} -D {データベースのホスト名} -DE - データベースを分離した構成でFlow Management Optionを利用している場合に、 データベースサーバーのホスト名またはIPアドレスを変更する。
AWMSHostnameSetup.exe -D {データベースのホスト名} -DE
- 注記 Flow Management Optionがインストールされたサーバーのホスト名またはIPアドレスを変更する場合には、-Dオプションを使用する必要があります。
対策
本不具合を修正するためには ApeosWare Management Suite 2 バージョン 2.2.2 以降へアップデートしてください。
富士フイルムBIダイレクト ApeosWare Management Suite 2 / ApeosWare Management Suite 1.4 ダウンロードページ