登録日: 2022年4月6日
最終更新日: 2022年9月14日
コンテンツID: 00727
対象環境
DocuWorks 8
現象
Windows Update(品質更新プログラム)を適用したPCで閲覧または印刷する際、DocuWorks文書内のBIZ UDゴシックなど一部のフォントの文字が崩れて表示されます。
原因
2022年2月のWindowsの更新プログラムにより、Microsoftが提供する一部フォントにおいて形状の変更がありました。
その影響のため、更新プログラム適用前に作成したDocuWorks文書に該当フォントが含まれている場合、更新プログラム適用後の環境での文書の閲覧または印刷時に、フォントの表示が崩れて文字同士が重なって表示される問題が発生することがあります。
変更が行われたフォントは次の通りです。
- UD デジタル 教科書体 N-R
- UD デジタル 教科書体 N-B
- BIZ UDゴシック / BIZ UDPゴシック
- BIZ UD明朝 Medium
フォントへの変更が実施された品質更新プログラムは次の通りです。
- Windows 11
2022 年 2 月 15 日 — KB5010414 (OS ビルド 22000.527) プレビュー - Windows Server 2022
2022 年 2 月 15 日 — KB5010421 (OS ビルド 20348.558) プレビュー - Windows 10, version 21H2, 同 version 21H1, および version 20H2
2022 年 2 月 15 日 — KB5010415 (OS ビルド 19042.1566、19043.1566、および 19044.1566) プレビュー - Windows 10 version 1809 および Windows Server 2019
2022 年 2 月 15 日 — KB5010427 (OS ビルド 17763.2628) プレビュー
対処方法
DocuWorks 8.0.15以降へのアップデートで改善します。
会員制のポータルサイト「富士フイルムBIダイレクト」から「DocuWorks 8 アップデート 最新版」のダウンロードができます。
8.0.15以降を適用いただくことにより、本現象が発生しなくなります。
補足
アプリケーションから変換したDocuWorks文書を別のPCで閲覧または印刷する際、閲覧側の環境にてフォントファイルの有無やバージョン差異などの違いがあると、フォントの代替や形状変更による表示の差異や崩れ、場合によっては文字化け等が発生する可能性があります。
そのような影響を防ぐために、下記のDocuWorks Printerの印刷設定の変更もしておくこともおすすめします。
DocuWorks Printerの印刷設定([画質]タブ)にある「すべての文字を図形データに変換する」を選択する。
- Windowsのスタート>「設定」>「デバイス」をクリックします。
- 「プリンターとスキャナー」>「DocuWorks Printer」>「管理」>「印刷設定」をクリックします。
- 「画質」タブの「すべての文字を図形データに変換する」を選択し、「OK」ボタンをクリックします。
- 「DocuWorks Printer」と表示されているWindows設定画面を閉じます。
- DocuWorks文書への変換をお試しください。
上記を選択することで、変換したDocuWorks文書のデータサイズは若干増えますが、別のPCで閲覧または印刷した際、環境に左右されず、期待通りの表示となることが期待できます。是非ご検討ください。